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Agenda
• Part 1 — Micro-Controller Boards 

• Arduino and Energia


• Example: Install Energia


• Part 2 — LaunchPad and Energia 
• The LaunchPad Family 


• Discover the MSP432 LaunchPad 


• Example: Blink a LED


• Example: Port the Code to Another LaunchPad


• Part 3 — BoosterPack and Libraries 

• The BoosterPack Family


• Example: Install the Educational BoosterPack


• Example: Display Rainbow Colours


• Example: Read Temperature


• Conclusion — The Energia Ecosystem

All product names, logos, trademarks and brands cited herein are the 
property of their respective owners.  
All company, product and service names used in this presentation are 
for identification purposes only.  
Use of these names, logos, and brands does not imply endorsement.
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Who Am I?
• Screen name: Rei Vilo


• Consultant


• Founding member of the Energia 
project


• Contribute with tools and libraries


• Focus on industrial robots, smart 
sensors, displays, and IoT


• Website: Embedded Computing 
embeddedcomputing.weebly.com 
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Agenda

• Part 1 — Micro-Controller Boards 

• What Is Arduino?


• LaunchPad vs. Arduino


• Official and Third-Party IDEs


• Install Energia
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What Is Arduino?
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What Is Arduino?

• Framework


• Open-source


• Based on C / C++


• Relies on objects


• Derived from Hernando 
Barragán's master thesis 
Wiring - Prototyping Physical 
Interaction Design (2003), with 
Massimo Banzi as supervisor
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What Is Arduino?

• IDE or Integrated 
Development Environment


• Based on Processing


• Minimalistic design


• Edit, build, upload


• Serial console, no debugger


• GCC tool-chain
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What Is Arduino?

• Hardware


• Software 


• Tools


• Community 

• Generic name 

• Arduino Uno


• Arduino framework 


• Arduino IDE


• Forum and contributed 
libraries


• Open-source hardware and 
software
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MCU vs. MPU

• MCU aka. Micro-Controller Unit


• MPU aka. Micro-Processor Unit
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Inside the MSP432
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Inside the MSP432
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Perspective
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IBM PC LaunchPad 
MSP430G2

LaunchPad 
MSP432

Year 1981 2010 2015

Processor Intel 8088 MSP430G2553 MSP432P401R

Architecture bits 8 16 32

Speed MHz 4,77 16 48

RAM kB 16 0,5 64

ROM kB 40 0 32

Mass Storage kB Dual 160~360  
5¼" floppy disks 16 256

Price USD 1 600 ~ 3 000 4,30 12,99



© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page

Energia
• Framework and IDE specific for 

Texas Instruments boards


• Initiated in January 2012 by 
Robert Wessels 

 
 
 

• Forked from Arduino


• Open-source software
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LaunchPad vs. Arduino
Shared Features 

• IDE based on Processing


• Framework based on Wiring


• Underlying C / C++


• Tool-chain GCC


• Open-source hardware and 
software
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LaunchPad vs. Arduino
Shared Features 

• IDE based on Processing


• Framework based on Wiring


• Underlying C / C++


• Tool-chain GCC


• Open-source hardware and 
software


 

LaunchPad Features 

• Boards supported by Texas 
Instruments


• All boards with hardware 
debugger


• Energia libraries based on  
TI-DriverLib 


• RTOS extension with Energia 
Multi-Tasking based on TI-RTOS


• Three official IDEs
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• Code Composer  
Studio  
Based on Eclipse  
Cross-platform 
ti.com/ccs

Official IDEs

• Energia IDE 
Cross-platform 
energia.nu

• CCS Cloud 
Chrome add-on 
dev.ti.com
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• Code Composer  
Studio  
Based on Eclipse  
Cross-platform 
ti.com/ccs

Official IDEs

• Energia IDE 
Cross-platform 
energia.nu

• CCS Cloud 
Chrome add-on 
dev.ti.com
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• embedXcode  
for Xcode  
macOS only 
embedXcode.com

Third-Party IDEs

• Visual Micro  
for Visual Studio  
Windows only 
visualmicro.com

�21
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• embedXcode  
for Xcode  
macOS only 
embedXcode.com

Third-Party IDEs

• Visual Micro  
for Visual Studio  
Windows only 
visualmicro.com
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Which Code Do You Prefer?

• Same application


• Initialise an analog input


• Read the analog input


• Same MCU


• Cortex-M4F 
TM4C123GH6PM 

• Three options


• Registers


• ROM-ware


• Energia
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Which Code Do You Prefer?

Option 1: Registers
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Which Code Do You Prefer?

Option 2: ROM-ware
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Which Code Do You Prefer?

Option 3: Energia
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Why Using Energia?
• Higher level of abstraction


• MCU-independent code


• Portability across all supported LaunchPads


• Non-exclusive


• Access to underlying layers


• Robust


• Industrial-grade libraries and tools


• Rapid prototyping
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Install Energia

• Go to energia.nu


• Select your operating system


• Download and install


• If needed, install additional 
drivers required by your 
operating system

�28
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Tips and Tricks

Linux 

• Check files 
permissions


• energia.nu/guide/
guide_linux
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Windows 

• No space in path, 
use a root folder


• energia.nu/guide/
guide_windows

macOS 

• Nothing! 

• energia.nu/guide/
guide_macosx

http://energia.nu/guide/guide_linux
http://energia.nu/guide/guide_linux
http://energia.nu/guide/guide_windows/
http://energia.nu/guide/guide_windows/
http://energia.nu/guide/guide_macosx
http://energia.nu/guide/guide_macosx
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Proxy Configuration
• On macOS, call the menu  
 > Preferences 

➍

➊

➎

➋

➌

➏Network
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Select a Board

• Energia comes only with the 
MSP430 boards installed
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Install Other Boards

• Call menu Tools > Board > 
Boards Manager 
 

• Select MSP432 EMT Red


• Click Install 

• Check energia.nu and install 
additional drivers for your 
operating system
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Install Specific Drivers

Linux 

• No drivers, but 
udev rules


• energia.nu/guide/
guide_linux
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Windows 

• Install XDS110 and 
CDC drivers


• energia.nu/guide/
guide_windows

macOS 

• No drivers are 
needed


• energia.nu/guide/
guide_macosx

http://energia.nu/guide/guide_linux
http://energia.nu/guide/guide_linux
http://energia.nu/guide/guide_windows/
http://energia.nu/guide/guide_windows/
http://energia.nu/guide/guide_macosx
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Energia Interface
• From


•  menu Tools > Board > 
Boards Manager 
 

• Select MSP432 EMT Red


• Click Install 

• Check energia.nu and install 
additional drivers for your 
operating system
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Energia Tool-Bar
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CCS Cloud Interface
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Agenda

• Part 2 — LaunchPad and Energia 

• The LaunchPad Family


• Discover the MSP432 LaunchPad 


• Example: Blink a LED


• Example: Port the code to another LaunchPad
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MCU vs. MPU

• MCU aka. Micro-Controller Unit


• MPU aka. Micro-Processor Unit
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Inside the MSP432
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Inside the MSP432
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Perspective
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IBM PC LaunchPad 
MSP430G2

LaunchPad 
MSP432

Year 1981 2010 2015

Processor Intel 8088 MSP430G2553 MSP432P401R

Architecture bits 8 16 32

Speed MHz 4,77 16 48

RAM kB 16 0,5 64

ROM kB 40 0 32

Mass Storage kB Dual 160~360  
5¼" floppy disks 16 256

Price USD 1 600 ~ 3 000 4,30 12,99
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The LaunchPad Family

MSP430 Supported 
Boards 

• MSP430G2553 

• MSP430F5529 

• MSP430FRxxxx


• FRAM memory
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The LaunchPad Family
SimpleLink Supported 
Boards 

• Cortex-M3 CC13x0 sub-1 GHz


• Cortex-M3 CC32x0 WiFi


• Cortex-M4F MSP432P401R


• Cortex-M4F MSP432E401Y 
Ethernet


• Cortex-M3 CC2650 Bluetooth 
not supported due to license 
restrictions
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Other LaunchPad Boards
Not Supported by Energia 

• C2000 — up to Energia 17


• 32-bit MCUs


• Real-time process control


• Hercules 

• 32-bit ARM Cortex-R4F and  
-R5F MCUs


• Safety critical applications
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MSP432 LaunchPad
• MSP432P401R MCU 48 MHz 32-bit ARM 

Cortex-M4F with FPU


• Power consumption: 80 μA / MHz active 
and 660 nA RTC standby operation


• Digital: AES256 Accelerator, CRC, DMA, 
32-bit Hardware Multiplier


• Memory: 256 KB Flash, 64 KB RAM


• Timers: 4 x 16-bit and 2 x 32-bit


• Ports: Up to 4 I²C, 8 SPI, 4 UART


• 40-pin BoosterPack connector


• XDS-110ET emulator with EnergyTrace+


• Less than USD13
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MCU

Programmer  
Debugger
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ResetUSB

Isolation 
Jumpers

MCU

Programmer 
Debugger

RGB LED

User Buttons

BoosterPack 
Connectors

LaunchPad MSP432P410R�48© Rei Vilo — Presentation at ESIEE, May 17, 2018 — Page



© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page

Programmer 
Debugger

ResetUSB

LaunchPad MSP432P410R

Isolation 
Jumpers

RGB LED

User Buttons

BoosterPack 
Connectors

MCU
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More GPIOs
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A Sketch with Two Functions

• A program is called a sketch


• Two main functions:


• setup(), to run once


• loop(), to run repeatedly
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Hidden File and Include

• The standard main.cpp source 
file is hidden


• It contains the statement 
#include "Energia.h" to 
include the Energia framework 


• and the main() function which 
calls setup() and loop()
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The RED_LED GPIO
• RED_LED is the name of the red LED 

available on all the LaunchPads


• For MSP432,  
P2.0: port 2 bit 0


• For MSP430FR2433,  
P1_0: port 1 bit 0


• Selecting the board provides its 
definition


• Read the data-sheet at ti.com!


• Check the pins maps at energia.nu/
pin-maps

// MSP_EXP432P401R 
// 75 - P2.0 RED_LED 
static const uint8_t RED_LED = 75; 

// MSP430FR2433 
static const uint8_t P1_0 = 2; 
static const uint8_t RED_LED = 2; 

�52

http://ti.com
http://energia.nu/pin-maps/
http://energia.nu/pin-maps/


© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page �53



© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page �54



© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page

Using GPIOs
• Initialise a GPIO with 
pinMode()


• Use a GPIO with 


• digitalWrite() to write,


• digitalRead() to read


• See the documentation at 
energia.nu/reference


• Always use the pin numbers, 
not the pin names (port, bit)
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The setup() Function

• pinMode() sets the direction 
of the pin, here OUTPUT


• All functions are documented 
at energia.nu/reference


• Always use the pin numbers, 
not the pin names (port, bit)
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The loop() Function

• digitalWrite() manages the 
GPIO when used as output:


• LOW to clear


• HIGH to set


• delay() waits for a period set 
in ms


• All functions are documented 
at energia.nu/reference
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Final Sketch

• The blinking LED is the Hello 
World! for embedded systems
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Target Another LaunchPad
• Swap boards


• Call menu Tools > Board


• For users of MSP430FR2433


• Select MSP432 Red 


• For users of MSP432 Red


• Select MSP430FR2433


• Check the LED blinks as expected


• This is called Hardware 
Abstraction Layer, or HAL
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Play with the Examples

• Call menu File > Examples 

• Four options 

• Built-in Examples 

• Examples for Any Board 

• Examples for Selected Board 

• Examples for Custom Libraries  

• Select Built-In Examples > 
01.Basics > Blink

�62© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page
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Agenda

• Part 3 — BoosterPack and Libraries 

• Expand with BoosterPack


• Drive Devices through Libraries


• Example: Install the Educational BoosterPack


• Example: Display Rainbow Colours


• Example: Read the Temperature
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Expand with BoosterPack

• Hardware complement for 
LaunchPad


• Standard 20 or 40 pins


• To be stacked onto the 
LaunchPad 


• Large range from Texas 
Instruments and third-party 
providers
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The BoosterPack Family

Radios  

• Anaren sub-1 GHz CC110L


• Bluetooth CC2650


• WiFi CC31x0
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The BoosterPack Family

Displays 

• Sharp Memory Display


• Kentec 3.5" screen


• Pervasive Displays e-ink 
screen
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The BoosterPack Family

Multi-Sensors  

• Sensors


• Weather and IMU


• Grove


• Breadboard


• Educational Mark-II
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The BoosterPack Family

Power 

• Fuel Tank Mark-II


• INA226 Volt-Amp-Watt-meter
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The BoosterPack Family

Motor  

• DC-motor


• Stepper motor
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The BoosterPack Family

Other interfaces 

• Touch


• RFID


• Infra-Red Remote 

And many more... 

• Build your own!
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Educational BoosterPack Mark-II

• Second generation keeps:


• Red-Green-Blue LED


• 3-axis analog accelerometer


• Buzzer


• Microphone


• ...and adds:


• 16-bit colour 128x128 LCD screen


• Joystick and two buttons


• Temperature sensor


• Light sensor


• Output for servo motor
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Know the BoosterPack

• Read the data-sheet at ti.com!


• Check the pins map


• Go to energia.nu/pin-maps


• Select the BoosterPack


• Is the BoosterPack compatible 
with my LaunchPad?


• Check at dev.ti.com
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Check the Compatibility

• Go to 
dev.ti.com


• Select 
BoosterPack 
Checker

�75

http://dev.ti.com


© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page

Check the Compatibility

• Select the LaunchPad 
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Check the Compatibility

• Select the BoosterPack


• Check the compatibility
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Libraries

• Libraries are for software  
what BoosterPacks are  
for hardware


• The libraries add objects to 
the core framework


• Identify the libraries 
corresponding to the 
BoosterPack


• Call the menu Sketch > 
Include Library
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Add a Library

• Call the menu Sketch > 
Include Library > Manage 
Libraries... 

• Select the library and click 
Install
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Use a Library

• On the code, a library needs 
to be included


• At the very beginning of the 
program


• Add an #include statement, 

• With the name of the library, 
between <> or "", 

• And no final ; !
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Install the BoosterPack

• Identify the +3.3V mark


• Plug the BoosterPack onto the 
LaunchPad
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Display Rainbow Colours

• Display the rainbow colours 
using the RGB LED


• Hints 


• Find the pins


• Use PWM 


• Search the reference and 
examples for analogWrite()

R

G B
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Search Documents

• What documents do we have?


• Schematics 


• Pins map


• Data-sheet of the sensors


• Energia reference


• Energia examples

R

G B
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Display Rainbow Colours

• Pins are:


• 39: red LED + LCD


• 38: green LED


• 37: blue LED


• Name each pin for later reuse


• Configure the pins

R

G B
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Display Rainbow Colours

• Use either...


• #define redLED 39 

• ...or...


• const uint8_t redLED = 
39; 

• In the setup() function, 
initialise the pins

R

G B
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Display Rainbow Colours

• In the setup() function, 
initialise the pins


• with pinMode() function


• Test the pins separately


• with digitalWrite() 
function


• Does the red LED work?

R

G B
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Display Rainbow Colours

• Does the red LED work?


• If not, check J5 jumper is in 
position 1.RED LED!

R

G B
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PWM

• PWM or Pulse Width 
Modulation


• Duty cycle = period high / total 
period


• Energia function  
analogWrite(pin, value)


• pin: = pin number


• value: 0..255 for 0..100%
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Display Rainbow Colours

• To get random value for each 
LED, use random(min, max)


• Send the values to the pin 
with the analogWrite() 
function

R

G B
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Display Rainbow Colours

• Finally, print the values to the 
console


• Hints:


• Search the reference and 
use the examples for Serial


• Two steps: initialisation and 
use
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Display Rainbow Colours

• Open and check the console


• 24-bit depth colours or 
16,777,216 different colours!

R

G B
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Display Rainbow Colours

• The resulting program

R

G B
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Available Help
Texas Instruments 
Website ti.com  

• Data-sheet of the BoosterPack


• Schematics


• Data-sheet of the sensors 


• Compatibility with LaunchPad


• Examples


• Forum at e2e.ti.com

R

G B

Energia Website  
energia.nu  

• Pins map


• Language reference


• Libraries


• Examples


• Forum at 43oh.com 
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Agenda

• Conclusion — The Energia Ecosystem 

• To be continued... 


• IDEs


• General Resources


• Examples


• Social

�96



© Rei Vilo — Presentation at ESIEE — May 17, 2018 — Page

To Be Continued...
• Use Other Ports and Buses


• SPI, I²C, Slave I²C 


• Develop Your Own Library


• Debug an Energia project with 
CCS Cloud 


• Low Power Mode


• Wake-Up, EnergyTrace 


• Build Your Own BoosterPack

�97

• IoT


• sub-1 GHz, Bluetooth, WiFi, 
Ethernet


• RTOS Extension with Energia 
Multi-Tasking


• RTOS Components


• Galaxia Library


• What Will You Make?
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Third-Party IDEs 

• Visual Micro  
for Visual Studio  
Windows only 
visualmicro.com


• embedXcode  
for Xcode  
macOS only 
embedXcode.com 

 

IDEs
Official IDEs 

• Energia IDE 
cross-platform 
energia.nu  

• Code Composer  
Studio  
based on Eclipse 
cross-platform 
ti.com/ccs


• CCS Cloud  
Chrome add-on 
dev.ti.com
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General Resources
Texas Instruments 

• Website ti.com


• LaunchPad and BoosterPack 
boards ti.com/launchpad


• Online tools dev.ti.com


• Resource Explorer dev.ti.com/
tirex


• Compatibility Checker 
dev.ti.com/bpchecker
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Energia 

• Website energia.nu


• Getting Started energia.nu/
guide


• Reference energia.nu/
reference


• Pins Maps energia.nu/pins-
maps


• GitHub github.com/energia

http://ti.com
http://www.ti.com/launchpad
http://dev.ti.com
http://dev.ti.com/tirex
http://dev.ti.com/tirex
https://dev.ti.com/bpchecker
http://energia.nu
http://energia.nu/guide/
http://energia.nu/guide/
http://energia.nu/reference
http://energia.nu/reference
http://energia.nu/pins-maps
http://energia.nu/pins-maps
https://github.com/energia
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Energia 

• Website energia.nu
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dev.ti.com
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dev.ti.com
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energia.nu
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Examples
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Energia 

• Menu  
File > Examples 


Third-party 
  

• Hackster 
hackster.io/
texasinstruments

Texas 
Instruments 

• Gallery  
dev.ti.com/gallery  


http://hackster.io/texasinstruments
http://hackster.io/texasinstruments
http://dev.ti.com/gallery
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Forum 

• E2E forum  
e2e.ti.com 

Social

Social 

• @TXInstruments


• @energiaproject
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Third-Party 

• 43oh!  
43oh.com

http://e2e.ti.com
https://twitter.com/TXInstruments
https://twitter.com/energiaproject
http://43oh.com


What Will You Make?



Pushing Your Arduino 
Project to the Next Level 
with Texas Instruments

Discovering the Energia Ecosystem
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