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1. Introduction 
CoderCam™ is a Windows-based GUI application that controls the TC-EVM units for all the TransChip sensor families (CoderCam, AlgoCam, 2 
Megapixel AlgoCam). It enables you to capture still pictures and motion videos with a TransChip (TC) sensor, and to determine the format, size, degree 
of compression, camera controls and other parameters on the displayed image. The software is included in the TC-EVM kit. 

 The CoderCam family includes the VGA camera sensors (TC5740, TC5757). The AlgoCam family includes TC6030 with 1.3MP. The 2 Megapixel 
AlgoCam includes the TC7030 with two megapixels. The CoderCam software works with all of these families. There are two types of EVM boards. 
One for the CoderCam VGA family and the second for the both the AlgoCam families. 

This document describes how to assemble the TC-EVM kit and how to operate the CoderCam software. 

1.1 Platform Requirements 
The TC-EVM board can be connected to laptop or desktop computers, with the following minimum requirements: 

1.1.1 Hardware 

 Microprocessor Pentium III 

 RAM (Random Access Memory) = 128MB  

 VGA monitor 

 Recommended: CD-ROM drive 
The NEC USB controller (NEC-720101) has been found to be fully compatible with the TC-EVM board: NEC USB2 to PCI bridge and NEC USB2 
PCMCIA  (included in TC-EVM kit). 

1.1.2 Software 
TC-EVM boards and the CoderCam software operate under the following systems: 

Windows XP – works well in all cases. 

Windows 2000 – in most cases, CoderCam works well under Win2000, however, in some installations Win2000 may be missing a .dll (MSVCP60.DLL) 
which can cause CoderCam not to work 

All other operating systems are not currently supported. 
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2. Contents of the TC-EVM Kit 

2.1 EVM Kit for VGA (TC5700) Family 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

TC5740 Sensor 24-pin
TCEV-5740-01 

TC5747 Sensor 39-pin
TCEV-5747-01 

Adapter  
39 to 24pin 

TC5747A-24-39A 

EVM board for TC5700 family  

Tripod USB2 card for desktop 
PC 

USB2 card & power 
supply for laptop 

Plastic spacers & screws Support board USB2 cable 
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2.2 EVM Kit for AlgoCam Family (TC6030/TC7030) 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

TC6030 Camera Sensor 
TC6030MF24D 

EVM board for Megapixel ++ family 
TC6030/7030 sensors with 24-pin flex connector attach directly to the board 

Tripod TC7030 Camera Sensor 
TC7030MF24A 

USB2 card for desktop PC 

USB2 cable USB2 card & power supply for laptop 
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3. Hardware Installation 

3.1 Installing the USB2 Card 
Two USB2 cards are supplied with the TC-EVM Kit, one for desktop PCs, the other for laptop computers.  

Important 
To ensure proper operation of the TC-EVM, you must use ONLY the parts supplied in the TC EVM kit. Even if you have a USB2 outlet in 
your computer, you should use the USB2 supplied with the kit; this card has been tested extensively and is known to be reliable. 
If you are installing the USB2 on your laptop computer in a PCMCIA slot, you need to use an additional power supply as well, because the 
TC-EVM card needs more power than the laptop can supply. 

3.1.1 USB2 for Desktop PC 
This section describes how to install the USB2 card in a desktop computer, and how to check if it has been installed correctly. 

 Shut down 

•  Click Start>Shut Down to shut down your desktop computer. 
Disconnect the power cable from the electric outlet.  

•  Use a Philips screwdriver to open the desktop case. 

                                        

USB2 card from kit 

Card Holder 
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•  Insert the USB2 card (from the TC EVM kit) into any one of the 
free slots on the motherboard. Press firmly into the slot and screw 
on the card holder (if a holder exists, remove it). 

•  Close your computer, reconnect to the main power outlet and boot 
the system. 

                                
 Check that the USB2 is connected properly, as described below: 

•  After rebooting the computer, select Start > Settings > Control 
Panel. 

•  Select System  and click the Hardware tab. 
•  Click on Device Manager to display a list of hardware devices 

active on your computer (see below). 

                                     

Insert USB2 card 
in free slot, press 
it in firmly. 

Click the 
Hardware tab. 

Click Device 
Manager 

Screw in USB2 card to 
computer chassis 
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 In the Device Manager window, check that USB2 Driver name appears. 

•  In the list of hardware devices that appears, click on: 
 “Universal Serial Bus controllers”  
and check if the  
“NEC PCI to USB Enhanced Host Controller xx”  
device is displayed  
(where xx may appear as the controller version). 

 If the device name is not displayed, shut down the computer, 
open the computer case and check if the USB2 card is firmly 
inserted in its slot, reboot and repeat the check. 
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3.1.2 USB2 for Laptop PC 
This section describes how to install the USB2 card in a laptop computer, and to check in the Device Manager if it has been installed correctly. 

 Shut down 

•  Click Start>Shutdown to shut down your desktop computer and 
disconnect it from the electric power outlet.  

 

•  Insert the PCMCIA USB2 card (from the TC EVM kit) and connect 
the power supply unit. 

 Installing the power supply is essential. The PCMCIA USB2 
card does not generate sufficient electric power to supply the 
TC-EVM. 

      
 

 

Insert USB2 card in laptop, press it in firmly. Connect power supply. 

USB2 card for laptops 
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 Check that the USB2 card is properly connected: 

•  After rebooting the computer, select Start > Settings > Control 
Panel. 

•  Select System, and click the Hardware tab. 
•  Click on the Device Manager button to display a list of hardware 

devices active on your computer (see below). 

                                     

 In the Device Manager window, check that the USB2 card is recognized. 

•  In the list of hardware devices that appears, click on “Universal 
Serial Bus controllers” and check if the TransChip USB2 device is 
displayed as: 
“NEC PCI to USB Enhanced Host Controller xx”. 
(where xx is the version number.) 

 If the above is not displayed, shut down the computer, and check 
if the USB2 card is inserted properly in its slot, then repeat the 
installation procedure, as described above. 

 

Select the 
Hardware tab. 

Click on the Device 
Manager button 
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3.2 Assembling the TC-EVM Unit 
3.2.1 TC Camera Sensors 

 Three types of TC camera sensors are available: 

1. TC5740 VGA sensor (uses 24-pin board to board connector) 

2. TC5747 VGA sensor (with flex 39-pin, uses 39-pin to 24-pin adapter) 

3. TC6030 1.3MP sensor (with flex 24-pin connects directly to EVM board)  

4. TC5740 (MF24D, MF24G, MF24F) VGA sensor (with flex 24-pin, directly to EVM board). See TC5740-MF24 Connection Options 

5. TC7030 2.0MP UXGA sensor (with flex 24-pin, directly to EVM board), similar to TC6030.. 
The general procedure of assembling the TC-EVM unit that applies to all three camera sensors is described below. 

  

 

 

3.2.2 Attaching the Support Board (for the EVM  TC5700 Family) 
•  Find the LEDs on the TC-EVM backside (see 

figure to the right). 
 

                    

LED 
location 

Backside of TC5700 Family 
EVM board 

TC5740MB24B sensor 
24-pin connects directly to 
EVM board 

TC5747MF39 sensor
Flex 39-pin connects 
to EVM board via 39-
to 24-pin adapter 

TC6030     / TC7030 
Flex connects directly to 24-
pin on board 
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•  Position the holder with the center hole over the 
LEDs, and the other two holes over the 
corresponding holes on the TC-EVM board. 

  

•  Use the plastic screws with spacers to attach the 
Support board to the TC-EVM board. Insert the 
spacers between the board and the holder.  

•  Gently tighten the plastic screws. 

   
 

For a description of connection of other types of TC5700 sensors, see TC5740-MF24 Connection Options. 

 You have now completed the assembly of the TC-EVM. in the next subsections you have a choice of connections that is dependant 
upon the TC camera sensor model and the type of connector. 

Spacers 

Position center hole over LEDs, and the 
other holes over the corresponding holes 
in the EVM board 
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3.2.3 Connecting the TC5740MB24B Sensor to the TC- EVM Board 
•  Press the TC-5740 sensor connector into the 24-pin 

connector on board. 
•  Attach the assembled board to the tripod (as shown in the 

figure). 
•  Remove the lens sticker and take care not to contaminate 

the lens surface. 

 Do not attach the USB2 cable from the TC-EVM unit to 
the computer yet; it needs to be done only after 
installing the CoderCam™ software.         
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3.2.4 Connecting the TC5747 Sensor to the Adapter / TC-EVM 
The 39-pin TC camera sensor requires a 39-to-24-pin adapter for attaching to 

the TC-EVM board. 
•  Before inserting the flex 

connector of the TC camera 
sensor into the adapter, lift 
up the clamp until it is 900 to 
the surface, insert the flex 
connector all the way to the 
end and press down firmly 
on the clamp to close it. 

 

 

 

•  Press the clamp hard to close on the flex connector and lock it in 
place. 

 

•  Press the TC5747 Sensor connector into the connector on the  
TC-EVM Board 

 

Open clamp all the 
way up (900) 

Push the flex connector into slot 
until it reaches the end. 

Close clamp on 
flex connector. 
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•  Attach the assembled board to the tripod (as shown in the 
figure). 

•  Do not attach the USB2 cable from the TC-EVM unit to the 
computer yet; it needs to be done only after installing the 
CoderCam software. 

 
 

3.2.5 Connecting the TC6030/TC7030 Camera Sensor 
 

 

 
    

EVM-TC6030/TC7030 board – top side  EVM-TC6030/TC7030 board – back side. 
1. Open the clamp on the connector all the 
way up (900 to surface of board)  

TC6030 camera sensor with lens face 
down. 
Connecting theTC7030 sensor is a 
similar procedure. 
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 Do not attach the USB2 cable from the TC-EVM unit to 
the computer yet; it needs to be done only after 
installing the CoderCam software.    

 

 2. Insert flex connector into back 
board connector and close the 
clamp firmly. 

 3. Attach the TC-EVM board to the tripod. 
Note that there is no need to attach a 
support board. The tripod screws on 
directly to the EVM board. 
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4. Software Installation 
This section describes the procedure of installing the CoderCam software.  

Before installing the CoderCam software, you need to configure the video display, as described in the first step below: 

4.1 Configuration of the Video Display 
 Set the video Display properties, as described below: 

Recommended: 1024x768 and 32-bit color for average monitors. However, you may set the 
display to fit your computer monitor. 

•  Right-click on the Windows desktop and select Properties. 
•  In the Display Properties window, select the Settings tab and set Screen 

Resolution = 1024x768 and “Color Quality = 32-bit. 
•  Click OK. 

 Older hardware may require a lower quality color setting, such as 16 bit. 

    
 Check that the TC-EVM unit is NOT connected to the computer via the USB2 
cable. 

 



 CoderCAM™ Evaluation Board Installation and Operation 

TransChip Confidential 21 

 Run “tceeinst.exe” from the installation CD, as follows: 

•  Insert the installation CD and wait a few seconds for the Explorer window to 
appear, displaying the contents of the CD. 

•  Double-click tceeinst.exe. 

 If you downloaded the installation program (tceeinst.exe) via the 
internet or some other method, the procedure is similar to that of 
installing from the CD. 

 

 The "Choose Install Location" option appears.  

•  Either accept the default destination folder or select another (click Browse 
and navigate to the required folder). 

•  Click “Install” to start the installation procedure.  
•  A window may appear prompting you to “Continue Anyway”. Click 

“Continue Anyway” (this may happen more than once). 

 

 Wait for "Setup was completed successfully." to appear at the top of the window: 

•  Click “Close” to complete the Installation. 

 Setup is now complete; proceed to “Connecting TC-EVM to USB2” and  
“Driver Installation”. under one of the following operating systems: 

o Windows 2000 
o Windows XP 

 

 

 

tceeinst.exe 

To cancel 
installation, click 
Cancel at any 
stage 



 CoderCAM™ Evaluation Board Installation and Operation 

TransChip Confidential 22 

4.2 Connecting the TC-EVM (VGA Family) to the USB2 
 Connect the TC-EVM to the USB2 card with the USB2 cable (make sure you are 
connecting to the port of the USB2 card you installed from the TransChip kit). 

 When attaching or detaching the TC camera sensor to / from the TC-
EVM board, always disconnect the USB2 cable. 
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4.3 Driver Installation 
Depending on your platform (Windows 2000 or XP), go to the appropriate section below: 

4.3.1 Windows 2000 - Automatic Driver Installation 
 After connecting the TC-EVM board with the camera sensor and it has 
been recognized by the system, the “Found New Hardware” window 
appears. 

 

 After a few seconds, the “Digital Signature Not Found” window may 
appear. Click Yes to continue. 

 

 

 The installation process continues. 

 It ends automatically without displaying a message and the 
“Found New Hardware” window disappears. 
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4.3.2 Windows XP – Automatic Driver Installation 
After connecting the Evaluation Board to the USB2 card with the USB2 cable, the 
system recognizes the new hardware, and the “Found New Hardware” window 
appears. 

•  Choose to install the software automatically. 

 

 

•  Click Next. (after checking that the “Install the Software 
Automatically” is activated. 

 

 

 

 

 

                              

 

Check that “Install the Software Automatically” is 
activated. Click “Next” 
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•  After a few seconds, the “Hardware Installation” window appears –  
click “Continue Anyway”. 

 

 

•  Installation continues.  
•  After completion, click Finish. 

 
 Second Phase of Win XP Driver Installation. 

•  For the second time, a "Found New Hardware" window appears. 
Repeat the steps above until the second installation phase is 
completed. 

•  Click Finish at the end of the process. 
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4.4 Recognizing the TC Camera Sensor  

This procedure describes how to check whether the computer recognizes the TC 
camera sensor. 

•  Select Start > Settings > Control Panel. 
•  Select System, and select the Hardware tab. 
•  Click on the Device Manager button to display a list of hardware 

devices active on your computer (see figure to the right). 

                                     

•  If the image TC camera sensor is properly connected you will see 
“Imaging Devices” appear in the list of hardware devices. Under it 
appears: 

. 
Where 4x may appear as the version number. 

 Check that the USB2 cable is disconnected from the TC-EVM 
board and proceed to launch the CoderCam program. The 
reason for connecting after installation of the program is to 
observe the “Connecting” message that appears 

 

 
 

Select the 
Hardware tab. 

Click on the Device 
Manager button 
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4.5 Post-Installation 
Successful completion of the installation automatically generates a "TransChip" folder under the Start Menu folder, and a TransChip icon on the desktop.  

•  Select Start  Programs  TransChip.  

The following options are available:  

 Doc – to open the user manual and other documents.  

 CoderCam – to operate the TransChip CoderCam program. 

 Uninst – to uninstall the CoderCam evalutation program. 
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5. The CoderCAM™ Interface 

5.1 Quick Start 
Select Start  Programs TransChip CoderCam.  
After launching the CoderCam program, the main screen is displayed.  

•  Connect the TC-EVM board via its USB2 cable.  
An “Initializing” message appears in the Status Bar at the bottom of the screen. 

•  If the Device Ready message appears after about 10 seconds or longer, the chances are that the connection is OK.  
•  If the message Device Ready appears too quickly after the Connecting message (within 3 seconds), there is a problem (see Troubleshooting 

Appendix).  

 “Device Ready” remains displayed until a Live Video window is opened.  

 You may connect the TC-EVM either before or after you launch the CoderCam program. 
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The CoderCam window appears (see figure on the right) 
The menu and toolbar are displayed as below:  

 
For a full description of the menu options and the icons, see (CoderCam 
Window – Options Icons and Shortcuts) 

 

•  Click the Live Video icon   or press Ctrl + V. 
A live video picture appears on your computer display, as received by the TC 
camera sensor without compression.  

•  Point the TC-EVM camera sensor at different physical objects to see how 
they appear on the computer display. 
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5.2 Links to Functions 
The list below contains links to the detailed explanations of the functions: 

Configuration of the Picture 
Display on Page 29 
To specify the output format, picture 
display size, Bayer representation, 
compression, internal JPEG and display 
orientation. 

Viewing Live Video - Procedure - 
Page 34 
To view a live image as transmitted 
from the TC camera sensor, or to 
compare a compressed-then-
uncompressed image with the sensor 
output. 

Device Properties – Page 34 
To specify the brightness, contrast, etc. 
of the image, to apply digital effects 
(negative, sepia, …), and to execute the 
capture of a displayed image. 

Operating Live Motion Video – 
Page 39 
To record and play live motion video. 
 

CoderCam Window – Options 
Icons and Shortcuts – Page 41 
Explains the function of all the icons, 
menu bars and status bars in the main 
window. 

Appendix – Troubleshooting– 
Page 44 
Solutions to common problems. 
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Scan Mode 
Works with RGB565 only - to set the orientation of the 
output picture. Every click on Change advances the 
beginning of the scan (the red arrow) one step 
clockwise. Default setting is “start scan from top left 

corner”  

See explanation below. 

5.3 Configuration of the Picture Display  
This section describes how to configure the display window. 

5.3.1 Settings Dialog Box (TC5700 Family) 
•  Select Options > Settings to display the Settings window. 
•  Selecting Options > Settings without a Live Video window open displays the Settings dialog box, as below. If a live video display is not open, a 

different Settings dialog box appears. 

 If the Output Format is defined larger than the capacity of the TC camera sensor, a blank (green or black) screen appears when you open 
the display screen. For example, if you define SXGA for a VGA camera sensor (such as the TC5740 and TC5747) an image will not display. 
 

                     

 

 

 

 

 

 

 

 

 

  

  

•  * With the TC5700 family camera sensors, if you wish to change the image output size to non-standard sizes, do so by 
incrementing/decrementing the Width by units of 16 pixels, and the Height by units of 2 pixels. For example, .if you have the size as 352x288 
(CIF) you can set the size to display 368x286. 

•  ** The format of a TC5700 picture can also be defined as Motion JPEG (MJPEG). For details see Motion JPEG (TC5700) on page 44 

Camera Output Format 
To set the format of the picture 
display**. 

Display Bayer 
When Output Format = Bayer, to 
specify the type of Bayer output 
(Bayer, Gray Scale, Raw Data). 

Preview Window Size  
For future use. 

Camera Output Size* 
To set the size of the picture display (automatically 
displays the dimensions in pixels). 

Video 
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Scan Mode 

The red arrow indicates the start point of the video scan, as described in 
the figures to the right. 

Scan Mode 

          
Normal   Mirror-X Mirror Y Mirror X+Y 

 

 

 

 

  

 

 

 

 

Load Defaults on Startup 
Not used in this version 

Adjust Main Window Size 
Adjusts the size of the main window to 
fit the video preview window size. 

Device ID 
Set to 0 (zero), unless you need to 
open several CoderCam applications 
with a different ID number for each. 

1 usb pkt/mf 
Activate when using internal on-board USB2 host 
controller and set the Output Format to QVGA 
(Default=Inactivate) 

LCD Interface  
 Check when using an LCD interface. Activated by 
default. 

Hardware Interface 

I2C 
Select to use the I2C interface. 

Parallel Interface 8 or 16 bit 
Activate when using a Parallel interface (activate 
box and re-connect parallel interface). Default is 
Inactive. 

Parallel 6 using I2C 
 Check when using 16-bit parallel I2C interface. 
Default is inactive. 

Modes 

Landscape (LCD Board) 
Displays a landscape image when 
using an LCD board. 

Bayer 8 bit 
Enables 8 bit mode, rather than the 
default 10 bit mode. 
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 SW Compression 
To specify the compression to apply to 
the image received from the camera TC 
camera sensor (JPEG, MPEG, D-JPEG).
If JPEG, set size = VGA or CIF, MPEG, 
D-JPEG available (depending on 
software version). 

Internal JPEG Format 
To define the quality and compression ratio of 
captured JPEG files, see explanation below. 

SW Compression 

Capture (TCX030 only) Size 
To set the size of the captured picture. 

… 
To select the directory in which to save the file. 

To capture the image, click the 
Capture icon  or the space bar.

Quality 
To select the quality of the JPEG. 

Save As 
To set the format of the capture image 
to be saved. 

Open Captured File 
Displays the screen capture. 

Thumbnail Enable 
Enables capturing thumbnails (not used 
in this version). 

Thumbnail Width/Height 
Sets the size of captured thumbnail images. 

Interleave 
Enables interleaving for captured thumbnail 
images.
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5.3.2 Options > Settings Dialog Box (with Live Video Display open) 
When a Live Video Display is open, the Options > Settings dialog box has limited options. The reason for this is that after a live video has been 
displayed according to defined settings, these settings should not be changed (only after closing the live video display). 

 
 

5.3.3 Defining the Display Parameters 

Output Format Output Size 
•  YUV 
•  RGB565 
•  RGB24 (TC574x only) 
•  Motion JPEG (TC574x only) 
•  Bayer 
 

•  UXGA -  1600X1200 (TC7030) 
•  SXGA -   1280X960 pixels (TC7030/TC6030) 
•  SVGA -  800X600 pixels (TC7030/TC6030) 
•  VGA   -   640X480  pixels 
•  CIF     -   352X288 pixels 
•  QVGA -   320 x240 pixels 
•  QCIF   -  176x144 pixels 
•  QQVGA -  160 x120 pixels 
•  QQQVGA- 80 x 60 pixels  

The options are similar to those in the 
Settings dialog box (above) when a 
live video picture is not open. 
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Bayer Representation Compression 

 Active only when you specify Bayer as the Output Format 
•  Bayer (in Bayer Grid format) 
•  Gray Scale (Y or G channel – color removed) 
•  As Is (Raw data from TC camera sensor) 
 

Compression to  apply to original image: 

•  JPEG (when selecting JPEG, select VGA or CIF as size. 

•  MPEG  

•  D-JPEG 

 MPEG4, D-JPEG and MJPEG are software version 
dependent (may not be available in all versions). 

 

Internal JPEG Format Display Scan Mode (active only with RGB565 output format) 
Subsampling (specifying the degree of JPEG compression) 

•    4:4:4 (higher quality, lower compression) 

•    4:2:2 (medium quality, medium compression) 

•    4:1:1 (low quality, higher compression 
Color space 

•    RGB (not relevant) 

•    YUV (not relevant) 

 
 

 

 

Normal Vertical 

Requires: 
Width & 
Height 

Mirror X 

Flips the 
image left 
to right 
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5.4 Viewing Live Video - Procedure 
You can view either uncompressed or compressed video. 

Uncompressed Compressed 
To view the picture as it is captured 
directly by the TC camera sensor. 

•  From the top menu-bar select 
View Live Video. 
or 
From the toolbar, click the  icon, 
or press Ctrl V. 
•  A Live Video window appears 
displaying the picture as seen by the 
TC camera sensor.  

To compare the original 
uncompressed video with the 
compressed-then-decompressed 
version.  

•  From the top menu-bar select 
View  Compressed Live Video. 
or 
From the toolbar, click . 
A Live Video window appears, 
displaying two panes. The left side is the original uncompressed video; the 
right side video has been compressed then decompressed.  

Notes 
•  For both Uncompressed and Compressed Video, the status bar at the bottom shows the Frame Rate, Compression Ratio and RGB value. 
•  To set the compression ratio, see Compression above. 
•  To move the Live Video window – left click on the window (the hand icon appears) and drag the window to its new position. 
•  After changing the settings, such as output format, output size or device properties (brightness, hue, etc.), they remain in effect even after 

closing and re-opening the CoderCam application. To return Device Properties to its default settings, click the Default button in the Device 
Properties Control window (in the Options menu). 

5.5 Device Properties 
•  Display the Video Settings window (below) by: 

o Selecting Options  Device Properties, or by clicking 

the Device Properties icon   on the top menu bar. 

The screens are explained below: 

 

Device Properties icon  

Original – from TC 
camera sensor 

Decompressed  
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Auto Settings 

Size - captured picture will be 
saved in this size.

Actual Size – size of the captured image actually displayed 
according to standard sizes (even when you change Width and 
Height). For example, if you specify 645x490, the image will be 
displayed at 640x480, the closest standard size to your setting. 

Quality – the degree of JPEG 
compression (1=highest compression 
and smallest file size). Click and drag 
to change. Index – the number to start incrementing the file name of the 

sensor JPEG capture. 

Settings 

TC5700 family - JPEG

Special Effects 

Capture – captures and saves the still JPEG image as received 
directly from the camera sensor. Click the Capture button (it is not 
necessary to click OK). The JPEG file (from the sensor) will be 
saved under the “Dir. Name” and the File Name you specified (see 
note below)

Motion JPEG – see Note below 

Path – directory path to which 
captured image are saved. 

File Name - name under which to 
store the captured image. 
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5.5.1 Image Saving 
When saved, the route the image takes depends on the option you choose to save the image. It also depends on the type of camera sensor. The options 
that allow saving are: 

 Capture square button in the Device Properties window (see screen above) 

 File > Save or the Save icon  (after clicking the Stop icon ). 

 Capture icon  on the top toolbar  

With the TC5700 family, the first option (Capture square button) takes the image directly from the sensor and saves it. The second option (File > Save) 

captures the image from the camera sensor streamed out via the parallel video interface (PVI). The third, JPEG Capture icon , performs handset 
capture simulation, by compressing the image and then decompressing it for display.  

With the TC6030, all options capture the image from the camera sensor streamed out via the parallel video interface (PVI). 

Notes 
•  When you click the Capture button (in the Device Properties window), the image is received directly from the camera sensor and is 

stored in the directory under the file name you specified in the two fields: “Dir Name” and “File Name”. The number “00x” will be 
appended to the file name, where “x” is the number in the “File Index” field. If, for example, in the above window you specified “2” in the 
File Index field, the file name will become “testvga1002”. After that, at every Capture, the File Index number is automatically 
incremented by 1 (the next file name, for example, will be testvga1003). 

•  If you wish to restore the original values in the dialog box, click the Default button. 

•  Motion JPEG (MJPEG) images can be displayed in different compression ratios, see Motion JPEG (TC5700). 

 



 CoderCAM™ Evaluation Board Installation and Operation 

TransChip Confidential 39 

5.5.2 Settings Dialog Box 

Option Description Setting / Range* 

Settings 
Brightness Sets target brightness of auto exposure. Default value is 0. -3 to +3 

Contrast Apparent difference in brightness between light and dark areas of an image. -128 to +128 

Saturation Saturated colors are vivid, strong, or deep, as opposed to desaturated colors which are dull, 
weak, or washed out. 

-128 to +128 

Hue That attribute of a color by which we distinguish red from green, blue from yellow, and so on. -128 to +128 

Sharp/Blur Sharpness is the high definition of edges in an image. Blur is the fuzzy, unfocused appearance. -128 to +128 

Gamma Adjustments to digital image data transmitted to the display monitor to compensate for the 
monitor’s luminance display capability. 

0.1 to 1.0 in steps of 
0.01 

Framerate Limits 
 

Determines the frame rate range. The values above the slider on the left and right represent the 
minimum and maximum frame rates set by the module’s firmware. 

Min – the minimum frame rate to be applied. Move the slider to select a value. The selected value 
is displayed in the text box on the right. 

Max – the maximum frame rate to be applied (depending on the frequency of the fluorescent 
lighting). Move the slider to select a value. The selected value is displayed in the text box on the 
right. 

For a fixed frame rate, set the minimum and maximum rates to the same value.  

 

Depends on the module. 
See the module 
datasheet for more 
information. 

Default To re-apply the default values set in the factory for the control parameters.  

Save To save the current settings in a file for future use.  

Load To load previously saved settings.  

* Default settings may change from software release to another. 
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5.5.3 Auto Settings Dialog Box 

Auto Settings 
Auto Exposure Enables auto exposure. Active/Inactive 

Manual Exposure Duration of exposure. Clear the Auto Exposure check box to enable, then click and drag the slider 
to enter the duration of exposure in milliseconds. 

Slider 

Auto Flicker 
Cancellation 

Check the box to automatically set the flicker cancellation frequency. Active/Inactive 

Flicker Frequency Sets the flicker frequency. Clear the Auto Flicker check box to enable, then select the flicker 
frequency value from the drop-down list. 

Drop-down list 

Auto White Balance Enables adjusting individual colors to eliminate unwanted color bias.  Auto/Manual 

Manual White Balance Manually adjust white balance. Not supported in this version Drop-down list 

Auto Shading 
Cancellation 

Check the box to compensate for “fall-off” (shading) at picture corners (vignetting).  
 

Active/Inactive 

Shading Cancellation 
Power 

Select the level of shading compensation, from 0 to 100. Active for Auto mode only. Slider 

Auto Backlight 
Compensation 

Backlighting – to activate adjustment for backlighting (camera parameters are optimized for image 
center) . Not supported in this version. 

Active/Inactive 
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5.5.4 Special Effects Dialog Box 

Special Effects 
None Displays a normal picture. Active/Inactive 

Monochrome Displays images in shades of black and white. Active/Inactive 

Negative Mono/Color Replaces each pixel color with its opposite on the color wheel. The new image is like a 
photographic negative. 

Active/Inactive 

Sepia 1/2/3/Green Applies a warm color tone to the image: 

Sepia 1: Applies a yellowish green tone. 

Sepia 2: Applies a brown tone. 

Sepia 3: Applies a blue tone. 

Sepia Green: Applies a green tone. 

Active/Inactive 

Posterize (color, mono) Reduces the number of bits per color channel, decreasing the number of colors and levels of 
lightness in the image and resulting in a flatter-looking image (TC6030 only). 

 

Active/Inactive 

Binary Displays the image in black and white only. Active/Inactive 

Solarize (color, mono) Simulates the distortion, in color or in shades of gray, resulting from over-exposure. Active/Inactive 
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6. Operating Live Motion Video 
To record and play a live motion video of a scene you capture with the TC-EVM unit. 

Below is a description of how to record and play a short scene. Further on is a list of icons that are used in the Live Video session. 

6.1 Procedure 
 Click the Live Video icon   to display the Live Video window (assuming that your TC-EVM is connected and operating). 

If you wish, adjust the size of the display image and other controls (brightness, contrast, etc.). Otherwise, you can proceed immediately to record. 

 Click the Record   icon to start recording. The camera will record the scene as shown in the display window. Move the camera or objects in the 
scene.  

 Click the Stop Recording  icon. The camera terminates the recording session. 

 Select File > Save or click the Save   icon to save the video. Select a location and save as one of the following: 

1. *.tcs (TransChip) format to view the video with the TC-EVM application 

2.  *.avi format to view the video in any video application, such as RealPlayer or Windows Media Player. 

 The other formats in which you can save do not display motion video (*.yuv=raw data, *.bmp=bitmapped image,*.jpg=JPEG format). Note 
that yuv is raw data and cannot be viewed without an appropriate application. *.bmp or *.jpg files are still images captured from the video and 
do not store/display motion.  

 To continue display motion video, click Play  again.  
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6.2 The Live Motion Video Icon Bar 

 

 
Play–plays a selected video. 

 
Record– starts to record a video. 

 
Stop– stops recording and play. 

 
Next Frame– moves the video forward one frame (available after stopping the video). 

 
Previous Frame– moves the video back one frame (available after stopping the video). 

 
First Frame– rewinds the video to the beginning (available when viewing a saved video). 

 
Last Frame– advances the video to the end (available when viewing a saved video). 

 
Player Loop–continuous video play - returns automatically to the first frame when the last frame is reached (available when viewing a saved 
video). 

 
JPEG and DJPEG operations – performs handset capture simulation.  
With the TC5700 family, this option performs handset capture simulation, by compressing the image and then decompressing it 
for display. After performing the capture, the image display stops. Close the image display and re-open. 
With the TCX030, this option (and all save options) captures the image from the camera sensor streamed out via the parallel video interface 
(PVI). With TCX030 it is possible to save in .bmp format as well as JPEG. The pre-defined capture settings apply to the captured image. 
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7. Motion JPEG (TC5700) 
To display a series of JPEG images in motion. 

 Define the format as MJPEG 

•  Open the Options > Settings > Video dialog box and select MJPEG 
as the display format. 

•  Click the Live Video Preview icon to display the image (or press 
Ctrl V). 

An image appears in the display window. 
 

 
 Adjust the quality and compression ratio by dragging the Quality slider.  

•  Open the Options > Device Properties dialog box and select the 
TC574x JPEG tab. 

•  Drag the slider to the left to decrease quality and increase the 
compression ratio and vice versa. 

The frame size in bytes appears in the Frame Size field. The compression ratio 
appears in the Ratio field  

  
 

 

 

To adjust Compression vs 
Quality, drag the slider.  

Drag left to decrease quality and 
increase the compression ratio 
and vice versa. 
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8. CoderCam Window – Options Icons and Shortcuts 

 

File 

 Standard Windows commands. 

View 

  Standard Windows commands. See  8.1 Top Menu Bar for details. 

Options 

 Settings (Options > Settings Dialog Box (with Live Video Display open) page 34) 

Device Properties (Device Properties on page 36) 

Adjust Window Size (Ctrl A) – press Ctrl A set the window size as the image size. 

Windows 

 Standard Windows commands 

Ctrl T closes all toolbars and windows except for the Live Preview window. Clicking Ctrl T 
again re-opens all windows and toolbars. 

When the Live Preview window is not open, the option File > Convert appears. This is for 
advanced users to convert YUV CIF and YUV QCIF to TCS (.tcs extension). 
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Player 

 Enables control of video output. See The Live Motion Video Icon Bar for details. 

 

8.1 Top Menu Bar 

 

 File > Open – opens .tcs or .jpg files.  

 
File > Save– saves still images (*.bmp, *.jpg), or motion video files (*.tcs, *.avi), after clicking the Stop icon. The JPEG file is saved after 
transmission to the computer (and not directly from the TC-camera sensor).  

 Options > Device Properties (Ctrl F)–to specify brightness, contrast, etc. Also, to define digital effects, and to execute a capture. 

 View > Live Video– displays the original image as transmitted by the camera. 

 
View > SW Compression – opens two windows, the left displaying the original image from the camera, and the right displaying the image 
compressed by the software, according to parameters defined in the Options > Settings dialog box (Settings Dialog Box (TC5700 Family). 

 
Stabilization– opens two windows, one displaying the original image from the camera, and the other displaying an image stabilized by the 
software.  

 

Reconnect EVB/Firmware Upload- performs two functions.  
1. While Live Video Preview is On, this button uploads the firmware.  
2. While Live Video Preview is Off it reconnects the EVB (to reset the system). 

 Play– plays a selected video. 
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 Record– starts to record a video. 

 Stop– stops recording and play. 

 Next Frame– moves the recorded video forward one frame. 

 Previous Frame– moves the recorded video back one frame. 

 First Frame– rewinds a recorded video to the beginning 

 Last Frame–advances the recorded video to the end. 

 
Player Loop– continuous recorded video play - returns automatically to the first frame when the last frame is reached (available when viewing 
a saved video). 

 

 

 

 

JPEG and DJPEG operations – performs handset capture simulation.  
With the TC5700 family, this option performs handset capture simulation, by compressing the image and then decompressing it 
for display. After performing the capture, the image display stops. Close the image display and re-open. 
With the TCX030, this option (and all save options) captures the image from the camera sensor streamed out via the parallel video interface 
(PVI). With TCX030 it is possible to save in .bmp format as well as JPEG. The pre-defined capture settings apply to the captured image. 

 

8.2 Bottom Status Bar 

 

 Frame Rate– real frame rate as derived from the camera.  

 Frame– current frame and the total number of frames (available when playing an existing file). 

 Progress Bar– progress of operations, such as when saving and opening files. 

 Color Components– color mix (RGB) at the mouse cursor position on the image. 

 Coordinates– displays the coordinates at the mouse location on the image. 
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8.3 Keyboard Shortcuts 
Ctrl A Adjusts window to image size Ctrl T Closes all toolbars, options and windows except for the Live 

Preview Video window. Click Ctrl T again to restore. 

Ctrl P Opens the Device Properties dialog box Ctrl O  To open a saved image or video. 

 



 CoderCAM™ Evaluation Board Installation and Operation 

TransChip Confidential 49 

9. Appendix – Troubleshooting 
 
Problem – First-time Launch of CoderCam 
After launching CoderCam for the first time, if the message 
Device Ready (on the status bar at the bottom of the screen) 
appears within 3 seconds, there is a problem 

To find the cause, : 

1. Disconnect the TC camera sensor (and adaptor, if available) from the TC-EVM 
board and reconnect. If this does not work proceed to the next stage. 

2. Connect only the TC-EVM board (removing TC camera sensor and adapter). 
A message should appear in the status bar: “Connecting” then “Device Ready” 
within 3 seconds. Select Start > Settings > Control Panel and click on 
Hardware >Device Manager. Check if Imaging Devices displays an error 
message (indicating a problem with the TC-EVM board). Replace the TC-EVM 
board. 

3. If the TC-EVM board is OK, replace the TC camera sensor and its adaptor (if 
available) with a new set. 

4. If all fails, call TransChip Support. 

Intermittent problems. Check to make sure you are using the USB2 card included in the TransChip EVM Kit 
(either for your desktop or laptop computer). 

Problem –CoderCam behaves erratically 
While performing different functions, you may find that the 
display window is either black or green, and you cannot see a 
picture, or some other dysfunction that you cannot solve.  

It is possible that the firmware has been disrupted and needs reloading.  

•  Click the “Init TC camera sensor” icon . After a few seconds the firmware 
will be re-loaded. Click the Live Video button to view a normal picture. 

 

 



 CoderCAM™ Evaluation Board Installation and Operation 

TransChip Confidential 50 

10. TC5740-MF24 Connection Options 
This section describes various options on how to connect TransChip modules to the Evaluation Board. Before making the connections, assemble the 
EVM board according to the instruction in Attaching the Support Board (for the EVM  TC5700 Family). 
On the EVM board, pull up the connector lock bar, as shown to the 
right. 

 
Insert TC5740MF24G as shown to the right. After inserting all the 
way into the connector, push down the connector lock bar. 

 

Pull up the connector lock bar 
to allow insertion of the TC 
module. 
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Insert TC5740MF24D as shown to the right. After inserting all the 
way into the connector, push down the connector lock bar. 

     

Insert TC5747MF24F as shown to the right. After inserting all the 
way into the connector, push down the connector lock bar. 

        

Attach the tripod, as shown to the right. 

 
 


