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UTILISATION DU LOGICIEL CADENCE POUR LA SIMULATION ET LE 
ROUTAGE 

 
  

 
 
Nous décrirons dans ces quelques pages les bases de l’utilisation du logiciel de saisie de 
schéma, de simulation analogique de circuits électriques et de routage. Il ne s’agit pas d’être 
exhaustif et de décrire complètement le logiciel; il faudrait quelques centaines de pages.  
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1. Organisation typique d’un logiciel de routage 
 
Les logiciels de routage disponibles sur le marché sont nombreux : Protel, Orcad, Pspice 
Design Lab, Proteus, Mentor, Cadence, PADS… Ils sont organisés quasiment de la même 
façon c’est à dire que les mêmes étapes doivent être franchies avant de concevoir un circuit 
imprimé. 
Ces étapes quelles sont elles ? 

� Saisie de schéma avec le logiciel Capture pour Orcad visible sur la gauche de la Figure 
1. 

� Définition de la forme du composant dans le schéma par Library Explorer. Le circuit 
PIC 16F873 a été dessiné sous le gestionnaire de « Library ». 

� Attribution des empreintes de composants (footprint) ou spécification des boîtiers en 
relation avec le schéma. 

� Génération d’une liste de connexions entre les composants appelée Netlist. 
� Chargement de la netlist et placement des composants sur le circuit imprimé à gauche 

sur la Figure 1. 
� Routage c’est à dire placement des connexions entre les composants. On obtient alors 

un circuit imprimé ou un PCB pour (Printed Circuit Board). 
 

 

Figure 1 : schéma électrique et carte routée 

 
2. Saisie de schéma et simulation électrique 

2.1. Création du projet 
 
La Figure 2 montre le lancement de l’outil de création de schéma (Capture ou Design Entry 
CIS).  
 



Utilisation du logiciel Cadence pour les PCB  P. POULICHET 3 

 

Figure 2 : lancement du logiciel de saisie de schéma 

 
La Figure 4 ci-dessous apparaît. Faire File > New > Project pour créer un nouveau 
projet. Un projet est un ensemble de plusieurs fichiers (schéma, bibliothèque de 
schéma, bibliothèque de PCB et PCB) qui serviront à générer le PCB. 
 

 

Figure 3 :  

 

Figure 4 : ouverture projet 
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Figure 5 : ouverture d’un projet blanc 

 
L’ouverture d’un projet blanc créer un nouveau projet sans aucune liaison avec les autres 
fichiers. 

 

2.2. Ouverture du schéma et placement des composant s 
 
Après les étapes ci-dessus, le schéma s’ouvre directement ou parfois il faut cliquer sur la page 
1 du schematic1 comme le montre la Figure 6. Les composants du schéma seront placés sur la 
fenêtre schematic. 

 

Figure 6 : ouverture schéma et fenêtre du schéma 

 
Pour ajuster le niveau de zoom, taper I (In) ou O (Out) agrandir ou diminuer de taille. 

2.2.1. Placement des composants 
 
Avec la fenêtre du schéma active (en cliquant sur la bande horizontale de la fenêtre du 
schéma), les menus du haut sont modifiés et Place > Part (Shift P) ou  permet de placer les 
composants sur le schéma. Si aucune librairies n’est installée, faire Add Library comme le 
montre la Figure 7. 
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Figure 7 : ouverture d’un répertoire de composants 

 
Quelques librairies courantes : 
 

� Pspice>Source pour les générateurs de tensions et courants : vsrc > source de 
tension continue, impusionnelle ou sinusoïdale, vsin > source de tension 
sinusoïdale avec offset, vpulse > source de tension rectangulaire. 

� Pspice>Analog résistances R, condensateurs C, inductances L (K_linear pour 
les mutuelles inductances), générateurs liés de tension ou courant commandés 
en tension ou courant E - F - G - H, 

� Pspice>ABM : additionneurs SUM, soustracteurs DIFF, dérivateurs DIFFER, 
filtres BANDPASS - BANDREJ... 

� Opamp pour placer les AOP (LF 356, LM 358…), 
� Oldlibs > Device : bibliothèque générique comportant résistances, capacités, 

diodes, transistors, connecteurs, relais… 
 

Quand un composant est sélectionné, on le place avec la clé de gauche ou la barre d’espace, 
on le tourne avec Shift + R (Rotate) et on termine le placement par Esc. 
Il est à remarquer qu’une fois qu’un composant a été sélectionné dans un schéma, il apparaît 
ensuite dans la fenêtre de la deuxième ligne en haut de l’écran et au milieu. 
 

2.2.2. Placement des connexions entre composants 
 
Fils de connexions 

Menu Place > Wire ou Shift W ou . 
Bus de liaisons 

Menu Place > Bus ou Shift B ou . 
 

Pour tracer une liaison, suivre le tracé du fil avec la clé de gauche. Pour annuler, clé de droite 
et End Wire. Il est parfois utile de nommer un fils de connexions par Place > Net Alias ou  
pour pouvoir retrouver facilement son niveau de tension dans les résultats de simulations. 
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2.2.3. Placement de la valeur d’un composant 
 

Il est possible de cliquer sur trois endroits du composants. Par exemple sur la figure ci-
dessous : 

 
 

R1 est le Part Reference du composant obtenue en cliquant sur R1. 
1k est sa Value. 
En cliquant sur le corps de la résistance, on accède à une ligne et il est possible de modifier le 
Part reference et la Value mais c’est moins pratique. 

 

2.2.4. Placement de la masse 
 
Place > Ground > 0/Source. 
 

2.3. Choix du type de simulation 
 

Pour simuler un circuit, il est possible de l’étudier de 3 façons différentes : en continu, en 
transitoire (en fonction du temps), en harmonique (en fonction de la fréquence). Pour définir 
le type de simulation on commence par définir un profil de simulation : Pspice > New 
Simulation Profile. Donner un nom de Profil de simulation ou en reprendre un existant. Puis 
Create.  
La seconde fenêtre permet de choisir le type de simulation : 

� simulation en fonction du temps Time Transient, 
� simulation en fonction de la fréquence AC Sweep/Noise, 
� simulation en fonction d’une tension continu DC Sweep, 
� calcul d’un point de polarisation Bias Point. 
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2.3.1. Analyse en continu 
 
Faire Place > Part > VDC. Cliquer sur 0Vdc. Changer la valeur de la tension continu du 
générateur.  

 

 
 

En cliquant sur le générateur en lui même, on accède à une ligne qui permet de changer la 
valeur de la tension continu : Value. 

 

 
 

2.3.2. Analyse temporelle avec une source de forme 
rectangulaire 

 
Les générateurs à employer dans ce cas sont VPULSE ou IPULSE. Avec ces générateurs, on 
peut réaliser n’importe quelle forme de signal rectangulaire. 

 
 

V1 est la valeur du niveau bas 

V2 la valeur du niveau haut 

TD (time delay) le temps de retard 

TR (time rise) le temps de montée 

TF (time fall) le temps de descente 

V1

V2

tr tf

PW

PER

Vpulse

t
PW (pulse width) largeur de la durée à l’état haut 
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PER période 

 
Modifier chaque valeur donnée dans le tableau précédent en cliquant sur le texte à gauche du 
générateur. 

 

 
 

Vsin est un générateur de tension sinusoïdale et Isin un générateur de courant sinusoïdal. 
VOFF est l’offset et VAMPL est l’amplitude crête du signal.  

 
Dans le menu Pspice > New Simulation Profile. Puis Create et Simulation Settings, choisir 
Time Domain (Transient).  

� Run to Time défini le temps de fin de simulation 
� Start Saving data after défini le temps du départ de l’enregistrement. 

 

2.3.3. Analyse fréquentielle 
 

Utiliser VAC comme générateur de tension sinusoïdale. Vac est la tension sinusoïdale en 
valeur crête et Vdc sa valeur moyenne. VAC est différent de Vsin car le 1er s’utilise pour 
l’analyse fréquentielle tandis-que Vsin s’utilise pour l’analyse temporelle. 

 

 
 
Dans le menu Pspice > New Simulation Profile. Puis Create et Simulation Settings, choisir 
AC Sweep (Noise). Quand la plage de variation de la fréquence est supérieure à 10, 
choisir une variation en fréquence de type logarithmic. 

� Start Frequency  défini la fréquence de début de la simulation, 
� End Frequency  défini la fréquence de fin de la simulation, 
� Points / Decade défini le nombre de points de calcul sur une décade de 

fréquence. 
 

2.4. Lancement de la simulation 
 

Vous pouvez placer des marqueurs  (respectivement tension, tensions 
différentielles, courant et puissance) sur le schéma ce qui permettra de tracer directement les 
courbes dès l’ouverture du logiciel de visualisation des résultats Probe.  
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Après la saisie du schéma et la définition du profile de simulation, lancer la simulation par 
Pspice > Run ou la touche F11. 
 
En cas d’erreur dans la simulation, examiner attentivement le fichier Pspice > View Output 
File. Dans ce fichier il est détaillé la liste de tous les composants et l’analyse de la simulation. 
Rechercher le mot error pour trouver la cause de l’erreur. 
 

 
3. La visualisation des résultats : logiciel Allegro AMS Simulator 
 
Allegro AMS Simulator est le logiciel de visualisation des résultats de la simulation. Il permet 
en effet de visualiser tous les courants et tensions dans un montage mais aussi des 
combinaisons ou fonctions mathématiques appliquées sur les courbes. 
 
La figure suivante montre la fenêtre de visualisation des résultats. Pendant la simulation, la 
fenêtre en bas à droite décrit l’avancement. 
 
Pour afficher des nouvelles courbes, faire Trace > Add Traces. Les signaux disponibles sont 
alors dans la nouvelle fenêtre de gauche et les fonctions mathématiques que l’on peut utiliser 
sont dans la partie de droite. 

 
 
Pour rajouter un autre axe sur le même graphique comme sur la figure précédente, appliquer la 
commande : Plot > Add Plot to Windows. Pour définir l’échelle de l’axe, menu Plot > Axis 
Settings. 
 

Pour utiliser les curseurs utiliser le bouton . Sélectionner la trace en cliquant avec la clé de 
gauche à l’endroit de I(V1)  sur la figure précédente et avec la clé de droite pour le 2ème 
curseur. 
 
Les principales fonctions que l’on peut appliquer sur les courbes sont les suivantes : 

P[] : phase en degré 
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DB[] : amplitude en décibels 
ABS[] : valeur absolue 
SIN[] : sinus en radian 
COS[] : cosinus en radian 
RMS[] : valeur efficace 

 
3. Paramétrage d’une simulation 
 
On utilise cette fonction pour voir l’effet sur la simulation, de plusieurs valeurs d’un 
composant. Il faut : 

• changer la valeur (Value) du composant pour la remplacer par {rvar} par exemple, 
• inclure dans le schéma un PARAMETERS. Ouvrer alors PARAMETERS et définissez 

une nouvelle colonne (New Colomn) portant pour nom rvar et pour valeur 100. C’est 
une valeur par défaut. 

• Dans le menu de simulation, définir Parametric Sweep > Global parameter > 
Parameter name : rvar. Entrer alors la liste des valeurs séparées par un espace 10 10k. 

 

 

Figure 8 : analyse paramétrique 

 
4. Attribution des empreintes des composants 
 
On peut sélectionner un à un chaque composant et attribuer l’empreinte (PCB footprint) sur la 
ligne qui apparaît. On peut également sélectionner plusieurs composants, ou bien tous les 
composants par Ctrl A puis faire Edit > Properties (ou Ctrl E) et on accède à un tableau 
similaire à celui de la figure ci-dessous. 
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Modifier la colonne PCB Footprint. 
 
5. Création d’un nouveau symbole sous Schematic Allegro 

5.1. Création d’une nouvelle bibliothèque 
 
Faire File > New > Library pour créer une nouvelle bibliothèque. Changer son nom en 
cliquant dans la fenêtre hierarchy. Dans la librairie, sélectionner avec la clé de droite et faire 
New Part. 

 
 
La fenêtre de la Figure 9 s’ouvre et lui donner un nom. Dans la fenêtre suivante, 

utiliser l’icône  pour placer les broches du composant et obtenir 
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Figure 9 : New Part Properties 

 

 
 

Figure 10 : Symbol d’un composant 

5.2. Association d’un modèle spice 
 
Les fichiers utile sont : fichiers modèles avec l’extension .lib et le fichier de la liste des 
composants (ou Part) avec l’extension .olb. 
Les modèles Spice sont placés à l’emplacement : C:\Cadence\SPB_16.01\tools\pspice\library. 
Ouvrir le logiciel Model Editor à l’emplacement : Cadence SP 16.01 > AMS Simulator > 
Simulation Accessories > Model Editor. Choisir l’option Choose Default Design Entry Tool 
Capture. Puis File New dans Model Editor. Puis Model > Import en choisissant l’option All 
Files (*.*) puis le fichier spice *.lib. File > Save pour enregistrer le modèle. 
Nous allons créer le Part c’est à dire ce qui va apparaître dans le schéma pour utiliser le 
modèle spice. Dans Model Editor, faire File > Export to Capture Part Library. Choisir les 
fichiers .lib et .olb comme le montre la Figure 11. 
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Figure 11 : choix du fichier spice de la liste des composants 

 
Valider la fenêtre suivante. Nous allons maintenant modifier le Part créé par la commande 
précédente. Dans Schematics, faire File > Open > Library et sélectionner le fichier 
NE5534.olb. Une fenêtre similaire à celle de la Figure 12 s’ouvre. 

 
 

Figure 12 : modification du Part 

 
La partie droite de la Figure 12 s’ouvre. On aura avantage à la modifier. Pour cela sélectionner 
le rectangle extérieur et le supprimer. Déplacer les broches pour qu ‘elles soient disposées 
comme sur la Figure 13. Rajouter les traits pour faire la jonction entre le rectangle et le 
triangle. 
 

 
 

Figure 13 : modification de Part 

 



Utilisation du logiciel Cadence pour les PCB  P. POULICHET 14 

Il est indispensable, pour déclarer la bibliothèque que l’on vient de créer, de faire Pspice > 
Edit Simulation Profiles > Configurations Files puis avec Browse, choisir le fichier 
NE5534.lib. Cliquer sur Appliquer. 
 

 
 

Figure 14 : déclaration de la bibliothèque 

 
6. Routage avec Layout 

6.1. Création de la Netlist 
Rendre active la fenêtre Hierarchy en sélectionnant le fichier.dsn. Le menu du haut est alors 
changé. 
 

 
 
Aller dans le menu Tools > Create Netlist. La fenêtre de droite s’ouvre. Entrer un nom de 
fichier pour la Netlist (extension MNL). Cliquer sur OK. 
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6.2. Chargement de la Netlist 
Ouvrir le logiciel Layout. Créer un nouveau fichier. Spécifier le Input Layout dans la fenêtre 
de gauche ci-dessous. Prendre le fichier par défaut default.tch. Cliquer sur Apply ECO puis 
Accept this ECO. 
 
 

     
 
Arrivé à cette étape, tous les composants sont placés aléatoirement sur la feuille et les 
connexions sont établies par l’intermédiaire de liaisons provisoires. Sélectionner le menu  
et déplacer les composants en cliquant dessus ; pour les faire tourner utiliser R. 
 
 
 
Spécification des couches à utiliser pour le routage : Tool > Layer > Properties. Cliquer sur 
Unused Routing pour la couche active. 
 
Pour imprimer les couches : Options > Post Process Setting. Sélectionner la couche avec la clé 
de gauche dans le tableau et faire Preview. SST est la couche composants. Pour modifier 
l’échelle d’impression, placer 1 dans la boîte sur la gauche et 2 dans la boîte de droite donne 
une impression à l’échelle ½. 
 
Pour modifier l’espace entre les pastilles, les pistes et les composants : Options > Global 
Spacing. Double cliquer sur la ligne en question. 
 
Pour déplacer une  pastille, aller dans Tool > Track > Select Tool et choisir la couche ou se 
situe la pastille à déplacer. 
 
Pour changer une géométrie après le routage, aller dans le menu Components qui se trouve en 
bas de l’écran derrière le routage. Sélectionner les Footprint Name en cliquant dessus et les 
changer par Properties. 
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Pour placer le pourtour du circuit imprimé, placer l’origine par Tools > Dimension > Move 
Datum et placer la nouvelle origine. Sélectionner la couche Global Layer 0. Cliquer sur l’outil 
Obstacle Tool . Cliquer sur le bouton de gauche à l’endroit ou vous voulez commencer le plan 
de masse et à chaque changement de directions. Cliquer sur le bouton droit et End Command 
pour terminer le plan de masse. Pour rattacher le plan de masse au nœud GND, double cliquer 
sur un point du plan de masse et sélectionner Net Attachment > 0. 
 
 
7.  Routage avec Allegro 

7.1. Création de la Netlist 
 
Rendre active la fenêtre Hierarchy en sélectionnant le fichier.dsn. Le menu du haut est alors 
changé. 
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Aller dans le menu Tools > Create Netlist. La fenêtre de droite s’ouvre. Allegro PCB Editor 
s’ouvre alors. 

7.2. Création des pastilles 
 
A titre d’exemple, nous allons créer une pastille ronde avec pour diamètre extérieur 10 mm et 
le diamètre de perçage de 2,54 mm ; nous lui donnerons le nom Pad400cir100d. Il est usuel de 
travailler en mils (millième de inch et 10 mm correspond à 400 mils). Il va principalement être 
défini le diamètre de perçage (Drill), la forme de la pastille et ses dimensions. Nous éditerons 
une pastille du type Pad120cir62d et modifierons ses dimensions pour qu’elle convienne. 
 
Lancer PCB Editor. Puis dans le menu : Tools > Padstack > Modify Library Padstack. Vous 
pouvez alors ouvrir les pastilles qui sont dans la bibliothèque sélectionnée par : Setup > Users 
Preference > Design_Paths > Padpath. La bibliothèque sélectionnée par défaut est celle ou 
sont stockées toutes les pastilles à l’adresse suivante : 
C:\Cadence\SPB_16.01\share\pcb\pcb_lib\symbols 
 
Remplacer Drill diameter de 61 par 100. En cliquant sur l’onglet Layers, vous accédez au 
menu de droite. Cliquer sur la ligne BEGIN LAYER, puis modifier la Geometry et les 
dimensions Width et Height (remplacer 120 par 400). Thermal Relief définie des dimensions 
supérieure à la taille de la pastille et est destinée à limiter l’élévation thermique de la pastille. 
Anti Pad est la dimension de la pastille à proximité d’un plan de masse. 
 

 

 
 

7.3. Création des empreintes 
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Pour visualiser les Footprint, faire : Place > Manually > Advance Setting et cliquer sur Data 
Base et Library. Faire Placement List > Package Symbol. Cliquer sur le composant concerné 
et il apparaît dans la fenêtre. 
 

 
 
 

Résistance RES500 (5 pas) 
Diode DIO500 (5 pas) 

Capacité non polarisé CAP196 (1 pas) 
Capacité non polarisé CAPCK06 (2 pas) 
Capacité non polarisé CAP300 (3 pas) 
Transistor (2N2222) TO18 
Boîtier circuit intégré DIP8_3 
Boîtier circuit intégré DIP16_3 

 

Tableau 1 : géométries les plus courante 

 
Lancer le logiciel PCB Editor. Faire File > New. Dans la fenêtre qui s’ouvre, remplir avec les 
données suivantes pour créer une géométrie BNC et spécifier l’emplacement ou elle sera 
sauvegardée : 
 

 
 
Pour placer les pastilles composant l’empreinte, Layout > Pins. Dans le menu Options sur la 
droite de la fenêtre, sélectionner la pastille qui convient. S’aider de l’indicateur de 
positionnement de la souris pour placer les pastilles. 
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Nous allons ensuite placer des rectangles autour des pastilles pour définir la place que prend le 
composant : silkscreen et Place_Bound.  
Faire Add > Rectangle. Sur le menu Options, choisir pour Active Class Package Geometrie et 
pour Subclass Silkscreen_Top. 
Faire Add > Rectangle. Sur le menu Options, choisir pour Active Class Package Geometrie et 
pour Subclass  Place_Bound_Top. 
Pour ajouter la référence, faire Layout > Labels > RefDes. Choisir pour Active Class Ref Des 
et pour Subclass Silkscreen_Top puis pour Active Class Ref Des et pour Subclass 
Assembly_Top. 
 

 
 
 
 
 


